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Introduction 1
Overview
The AIDA Colony Counting module provides an automatic counting of colonies in a cir-
cular or rectangular petri dish and 24 or 96 wells micro titer plates. It needs an image of 
the over named objects as input.
Introduction 5
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Starting Colony Counting
To select the Colony Counting mode:

1 On the tool bar, click the Evaluation button. 
A dialog box appears offering you a list of available evaluation modes.

Figure 1-1  Changing Evaluation Mode

The list entries reflect the installed AIDA application modules. 

2 Select the Colony Counting list item and click OK. 

Note – This evaluation mode is only available if you purchased the AIDA Colony 
Counting module. 
6 AIDA Colony Counting User’s Manual (Windows)



r a y t e s t

2

Using Colony Counting 2
Data Windows in Colony Counting
In addition to the AIDA standard data windows Image and Histogram the Colony Report 
data windows is available in the Colony Counting mode.
You can access this data windows by choosing the entry Colony Report from the View

menu

Figure 2-1 View Menu
Using Colony Counting 7
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Image Window in Colony Counting
All data are evaluated from the Image window. Although it might not always be on top, 
it is always open. The title bar of the Image window shows the full file path of the image 

You can copy the content of the Image window to the clipboard using the Copy Content 
command of the Edit menu. See the Export Image section in the AIDA Image Analyzer 
Basic Concepts and Features User's Manual for further explanation.
8 AIDA Colony Counting User’s Manual (Windows)
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Contextual Menu of the Image Window
In the contextual menu of the Image window in Colony Counting you can select all 
found colonies or delete selected colonies: 

Select All Colonies:
If there are some not selected colonies, 
the contextual menu, that opens after 
right-clicking, provides you with the 
commands Select All and delete if there 
are selected colonies for the selection.

Delete Selected Colonies:
If you have selected some of colonies 
or all of them, the contextual menu, that 
opens after right-clicking, provides you 
with the delete command for the 
selection.

Figure 2-2 Contextual Menu  
(Select All)

Figure 2-3 Contextual Menu  
(Delete)
Using Colony Counting 9
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Image Overlays
You can specify the label type and font you want to apply to the overlays (Segments of 
Search Area) using the Image Overlays command of the Options menu.

Figure 2-4 Options Menu: Opening the Image Overlays Dialog Box

After choosing Image Overlays from the Options menu, the Image Overlays dialog box 
opens allowing you to set the font, font size, and font style (bold, italic, roman typeface 
on white background) as well as the rotation (0°, 45°, 90°) for the labels. The detected 
lanes can be surrounded by a frame (Border Lines) and tracked by a Middle Line.

Figure 2-5 Image Overlays Dialog Box
10 AIDA Colony Counting User’s Manual (Windows)
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Colony Report Window
The Colony Report window consist of tables for each segment of Search Area, listing the 
area, circularity, integral and maximal intensity of particular colony.

Data Description
Available Columns in the Result Table:

The following additional rows can be found or created exclusively in the Colony Report:

You can select the number and type of columns you want to display using the contextual 
menu of any column in the window (see below).

To change the column order:

1 Click the heading of the column to be moved.

2 Press the mouse button and drag to the desired position in the table.

Table 2-1 Columns Available in the Result Table of the Profiles Window

Column Short Description
Number The number of the colony.
Area The area of the colony.
circularity The circularity of colony in range of [0.000-

1.000].
Position. [length unit] The position of the band in the image measured 

from the edges of the image.
Integral [signal unit] The integrated colony intensity.
Max Intensity[signal unit] The maximal Intensity in the region of colony.
signal unit and length unit = units of measurement, depending on the type of the imaging device used to 
obtain the image and the options set in the Image Attributes dialog box.

Table 2-2 Additional Columns in the Region Report

Total Number Displays the total number of found and created 
colonies in all Segments.
Using Colony Counting 11
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3 Release the mouse button.

Figure 2-6 Changing Column Order

To change the column width:

1 Position the mouse pointer over the border of the column whose width you want to 
change.

2 Click and drag the border in the appropriate direction. 

3 Release the mouse button:

Figure 2-7 Changing Column Width
12 AIDA Colony Counting User’s Manual (Windows)
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Contextual Menu of the Colony Report Window (Result Table)
Each column in the Result Table has a contextual menu attached. To open the contextual 
menu, right-click on the column heading (gray area).

Figure 2-8 Contextual Menu of the Profiles Window’s Result Table

With the first two commands of the contextual menu, you can sort the table of the Result 
Table by any value column in ascending order (A to Z or zero to 9) or descending order 
(Z to A or 9 to zero). Just choose the appropriate menu item (Sort Ascending by/Sort 
Descending by).
The Select/Unselect commands of the contextual menu are used to select/deselect a 
column to export. The column heading of selected columns are highlighted.
To hide a column, choose Hide command from its contextual menu. You can recover 
hidden columns using the Select Columns command (see below).
Using Colony Counting 13
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To specify the decimal digits for the value output in a column, choose Settings of from 
the contextual menu and enter the value for the decimal digits in the dialog box displayed.

Figure 2-9 Setting Output Format for Columns

Use the One-lined Header/Two-lined Header command to reduce or expand the column 
heading by one line (the second line indicates the units of measurement).

To select/deselect the columns that should be displayed in the Result Table: 

1 Choose Select Columns. 
A dialog box appears displaying two lists (Show Columns/Hide Columns). 

2 Select the columns you want to show or hide and click the appropriate arrow 
symbol to transfer the items between the two lists. 

3 To deselect a particular item, just click it again.

Figure 2-10 Columns Selection Dialog Box
14 AIDA Colony Counting User’s Manual (Windows)



r a y t e s t

2

Toolboxes in Colony Counting
In addition to the standard AIDA toolboxes Display Control and Publishing Layout, the 
Colony Determination toolboxes becomes available after selecting the Colony Counting 
mode.
You can access Colony Determination toolbox from the Evaluation menu or by clicking 
the appropriate button on the too bar.

Figure 2-11 Mapping between Evaluation Menu Entries and Toolbar Buttons
Using Colony Counting 15
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Colony Determination Toolbox
The controls of the Colony Determination toolbox allow you to define Search Area, set 
search parameters and edit new colonies. 

Figure 2-12 Colony Determination Toolbox (Overview)

search area determination pane

search parameters determination pane

manual colony manipulation pane
16 AIDA Colony Counting User’s Manual (Windows)
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To display the Colony Determination toolbox:

• On the main menu, click Evaluation and choose Colony Determination.
Alternatively you can click the Colony Determination button on the toolbar.

Search Area Determination Pane
The first step in the analysis of a Colony Counting-application is the determination of the 
Search Area. 

Figure 2-13 Search Area Determination Pane (Overview)

Once you determined an overlay of your search area, you can modify it before there are 
colony detected or created respectively the same way as described chapter Performing 
Colony Counting.

circular petri dish

rectangular petri dish

96 wells micro titer plate

24 wells micro titer plate
Using Colony Counting 17
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Colony Detection Pane
.

Figure 2-14 Search Parameters Determination Pane (Simple Mode)
18 AIDA Colony Counting User’s Manual (Windows)
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Figure 2-15 Search Parameters Determination Pane (Simple Mode)

This pane will be needed to determine the search parameters and start the search process. 
You can switch between the simple and advanced mode. In simple mode you have to 
create at least one example colony to let the program determine the appropriate 
parameters set while in advance mode you can set the parameters explicitly. Setting the 
search parameters is very important to obtain good results. 
Clicking the Reset button set the parameters to the default values. Click the Detect button 
to start the detection process.
Using Colony Counting 19
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Colony Edit Pane
This pane will be needed to create undetected colonies and disjoin connected colonies 
manually. Select the upper three boxes to create colonies with appropriate shape. For 
more details see chapter Performing Colony Counting.

Figure 2-16 Edit Colonies Pane

new polygonal colony

new auto-contour colony

new elliptical colony

disjoin colonies
20 AIDA Colony Counting User’s Manual (Windows)
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Publishing Layout Toolbox in Colony Counting
In AIDA Colony Counting the standard AIDA Publishing Layout toolbox is expanded by 
an additional button for specifying the print options for the Colony Report:

Print Options for Colony Report
Using the Colony Report button you can configure layout setting for the Report Table 
window. 

1 Click the Print Options: Colony Report button.
The appearance of the Protocol Print pane changes. 

Figure 2-17 Print Options for the Profiles Window

2 Select the appropriate options:
In the Format pane select the paper orientation (Portrait or Landscape) by clicking the 
appropriate radio button.
In the Print pane you can specify to print the table or not.
Using Colony Counting 21
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Print
In AIDA there are two ways for printing your image and evaluation data:

• Choose Print from the File menu, 
or

• Use the Protocol Print pane on the Publishing Layout toolbox.
The Print command of the File menu allows you to print your data 'on the fly' without 
permanently storing the layout/printing settings, whereas the Protocol Print pane 
provides you with a complete set of printing features which includes saving the setting 
with the data file for reasons of reproducibility.
Choosing the Print from the File menu opens the Print dialog box, allowing you to 
configure the printout to contain only the overlays and results that are currently needed. 
Click the check boxes for the various items to turn them on or off. Select the number of 
copies, you want to print.

Figure 2-18  Print Dialog Box
22 AIDA Colony Counting User’s Manual (Windows)
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The margins of the printout can be selected in the Edges part of the dialog box. The 
Header button displays the following dialog box:

Figure 2-19  Page Header and Footer Dialog Box

Here the Header and Footer of the report can be configured to contain various image and 
evaluation specific data.
The Parameter (data overlays), the Image and Colony Report information can be 
selected in the left part of the Print dialog box.
In the right part of the dialog box (Parameter and Image Options) you can select Whole 
Image, or Window Content from the first drop-down menu. Landscape or Portrait 
format can be selected from the second drop-down menu. The printing of Overlays, 
Grayscales, Scales, and Overexposed can be selected. The printout can be automatically 
fitted to the page, or the relative size of the image representation can be selected (in %). 
In the Colony Report Options pane you can specify the paper orientation (Landscape or 
Portrait) for the printout.

Preview
As for printing, in AIDA there are two ways of previewing pages before they are actually 
printed:

• Using the Print Preview option of the File menu, or
• Using the Preview button on the Publishing Layout toolbox.

The Print Preview option of the File menu opens the Preview dialog box, which allows 
you to specify the layout settings for the preview. The options presented here are the same 
as in the Print dialog box and those selectable from the various panes of the Publishing 
Layout toolbox. However, they are not stored with the data file.
Using Colony Counting 23
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The Preview option of the Publishing Layout toolbox allows you to preview all pages as 
configured in the Publishing Layout toolbox before they are actually printed. Clicking the 
Preview button opens the Preview window directly, since all layout setting are already 
made through the Print Protocol pane.

Figure 2-20 Preview Example Part 1
24 AIDA Colony Counting User’s Manual (Windows)
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Figure 2-21 Preview Example Part 2
Using Colony Counting 25
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Export and Import
In AIDA Colony Counting Colony Report table can be exported to be imported in other 
documents or programs. In addition the templates can be exported to be applied to other 
images. The various functions can be found in the Export and Import submenus of the 
File menu.

Exporting Templates

To export your own evaluation templates:

1 On the File menu, click the Export menu item and then choose Template from the 
submenu. 

2 In the Export Template dialog box that appears type a name for the export file and 
confirm the action by clicking Save, 

or

1 Click the Export Template button on the tool bar to open the Export Template 
dialog box

Figure 2-22  Main Toolbar (Export Template Button)

2 Type a name for the export file in the File Name text box and complete the export 
action by clicking Save.

Figure 2-23 Export Template Dialog Box
26 AIDA Colony Counting User’s Manual (Windows)
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Exporting Colony Counting Report Table

To export the Colony counting Report Table:

1 On the File menu, click the Export menu item and then choose Colony Report from 
the submenu. 

2 In the Colony Report Export dialog box that appears type a name for the export 
file. 

Figure 2-24 Colony Counting Report Table Export Dialog Box

3 Click Save to confirm the export.
You can specify the Range of the exported rows (Header only, All Rows or 
Selected Rows only) as well as the List Delimiter and Decimal Delimiter in the 
respective panes of the dialog box. Selecting the System Defaults button applies 
the Windows default settings to List Delimiter and Decimal Delimiter.

4 Complete the action by clicking OK. 
The data are saved to a simple ASCII (text) file.

Importing Templates

To import previously saved templates to another equivalent image:

1 On the File menu, click the Import menu item and then choose Templates from the 
submenu. 
Using Colony Counting 27
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2 In the Import dialog box that appears select the template to be imported and click 
Open.

Figure 2-25  Import Template Dialog Box

The imported Overlays can be arranged to fit the image by moving the whole overlay set 
using the AIDA standard overlay editing functions.
28 AIDA Colony Counting User’s Manual (Windows)
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Performing Colony Counting 3
Assigning Search Area and its Segmentation
The first step in the Colony Counting is the determination of the search area and its 
segmentation. The Search Area tells the module where to search for colonies and its 
segmentation organizes the Colony Report table in sub tables. The result is a fully 
evaluated image where all the information can be collected in a comprehensive printout.
With AIDA Colony Counting it is usually preferable to select all parameters that are 
necessary for an automatic detection of colonies. When all parameters are well chosen, 
further colonies can be automatically selected and assigned. The detected colonies can be 
than manipulated in shape an size and even divided if some connected colonies detected 
as one. Further it is a manual creating of colonies which does not fulfill the search 
parameter conditions.
To begin with the evaluation of Image it is important to set the Image Attributes via the 
Options menu first (see “AIDA Image Analyzer Basic Concepts and Features User's 
Manual” for details). If these settings are not correct further image evaluation will not 
produce meaningful results.

Figure 3-1  Image Attributes Dialog Box

The first step in the analysis of a Colony Counting-application is the determination of the 
Search Area.
Performing Colony Counting 29
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Search Area Determination
Select appropriate tool from the Search Area Determination pane to create a the Search 
Area for your application.

Figure 3-2 Search Area Determination Pane (Overview)

Once you determined an overlay of your search area, you can modify it before there are 
colonies detected or created respectively the same way as described below. Double click 
the confirmed overlay to enter the edit mode.
Circular Petri Dish Tool: Select this tool to create an overlay to determine the search area 
on a petri dish Image and its intersection if necessary. 

Figure 3-3 Circular Petri Dish Selection

To create an overlay on a circular petri dish:

1 Select petri dish box by a mouse click.

2 Press the mouse left button on an arbitrary point on the boundary of desired search 
area and drag to the opposite point on the other side of the boundary.

3 Release the mouse button. You are now in “create” mode.

4 Press the mouse left button and drag it to move the search area to a desired position 
and release it 

5 Double click on the boundary of the search Area intersect the search area to two 
segments. You can repeat this step till you have the appropriate segmentation of the 
search area. Once you create an intersection line, you can move this line by clicking 

circular petri dish

rectangular petri dish

96 wells micro titer plate

24 wells micro titer plate
30 AIDA Colony Counting User’s Manual (Windows)
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the mouse left button on an end of intersection line and drag it to a desired position 
and release it. Move the curser to an end of an intersection line and press the delete 
button to remove it.

6 you can change to “scale”, “rotate” and again to “create” modes by clicking the 
mouse left button once. In these mode you can change the size and the position of 
the search area.

7 Once you have created an appropriate search area with or without a segmentation, 
click the mouse right button to confirm your search area. 

Figure 3-4 Editing Circular Petri Dish with Segmentation

Rectangular Petri Dish Tool: Select this tool to create an overlay to determine the search 
area on a pteri dish Image and its intersection if necessary. 
Performing Colony Counting 31
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Figure 3-5 Rectangular Petri Dish Selection

To create an overlay on a rectangular petri dish: Select rectangular petri dish box by 
a mouse click.

1 Select petri dish box by a mouse click.

2 Press the mouse left button on the upper left edge of the petri dish and drag to its 
bottom right edge. The connection line of this points describe the diagonal of 
rectangular overlay, so you can choose these points in other ways.

3 Release the mouse button. You are now in “create” mode.

4 Press the mouse left button and drag it to move the search area to a desired position 
and release it 

5 Double click on the boundary of the search Area create an intersection line between 
the click position and the a point on the opposite edge with the same width or height 
respectively. You can repeat this step till you have the appropriate segmentation of 
the search area. Once you create an intersection line, you can move this line by 
clicking the end of the intersection line and drag it to a desired position and release 
it. Move the curser to an end of an intersection line and press the delete button to 
remove it.

6 you can change to “scale”, “rotate” and again to “create” modes by clicking the 
mouse left button once. In these mode you can change the size and the position of 
the search area.

7 Once you have created an appropriate search area with or without a segmentation, 
click the mouse right button to confirm your search area.
32 AIDA Colony Counting User’s Manual (Windows)
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Figure 3-6 Editing Rectangular Petri Dish with Segmentation

Rectangular Petri Dish Tool: Select this tool to create an overlay to determine the search 
area on a pteri dish Image and its intersection if necessary. 

Figure 3-7 Micro TiterPlate with 24 Wells Selection

To create an overlay for a micro titer plate:

1 Select on available micro titer plate. You can edit both available plates the same 
way.

2 Press the mouse left button on the upper left edge of the plate and drag to its bottom 
right edge. The connection line of this points describe the diagonal of the plate 
overlay, so you can choose these points in other ways.

3 Release the mouse button. You are now in “create” mode.

4 Press the mouse left button in the overlay but outside of the wells and drag it to 
move the whole search area to a desired position and release it. 

5 Click inside a particular well to adjust its position.
Performing Colony Counting 33
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6 you can change to “scale”, “rotate” and again to “create” modes by clicking the 
mouse left button once. In these mode you can change the size and the position of 
the search area.

7 Once you have created an appropriate overlay of the plate, click the mouse right 
button to confirm your search area.

Figure 3-8 Editing Rectangular Petri Dish with Segmentation

Setting Colony Detection Parameters
This pane will be needed to determine the search parameters and start the search process. 
You can switch between the simple and advanced mode. In simple mode you have to 
create at least one example colony to let the program determine the appropriate 
parameters set while in advance mode you can set the parameters explicitly. Setting the 
search parameters is very important to get good results. Clicking the Reset button set the 
parameters to the default values. Click the Reset button to start the detection process.
34 AIDA Colony Counting User’s Manual (Windows)
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Using simple mode to determine appropriate search parameters:.

Figure 3-9 Search Parameters Determination Pane (Simple Mode)

1 Click the Example Colony tool box, to create example colonies.

2 Press the mouse left button on a colony and drag around. An overall will be 
automatically created. You can drag around till you get the desired shape of the 
example colony and release the button. A right click confirm the creation of 
example colony. You can repeat this step several times. It is recommended to do this 
at least twice, one colony with the weakest intensity and one with the minimal 
allowed size. In this way you set implicitly the minimal intensity and the minimal 
allowed size of colonies. It is also recommended to create one or more large 
colonies if the size of large colonies is approximately larger than twice of the 
minimum. 

3 You can create a rectangular Background Region the same way as Example 
Colony. This set the minimal intensity in the parameters set. The current value of 
Min. Activity will be replaced with the average intensity in the background region 
if it is more than the current value of Min. Activity. Use advanced mode to set 
search parameters manually:
Performing Colony Counting 35
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Using advanced mode to set the search parameters:.

Figure 3-10 Search Parameters Determination Pane (advanced Mode)

In this pane you can set the search parameters explicitly.

1 You can determine the Search Level between 1-10. Search Level stays unchanged 
while you are in simple mode. Increasing this parameters increases the sensitivity of 
search algorithm. But a higher search level causes sometimes a longer search time, 
so it is recommended not to choose high levels if not necessary.

2 Trough Min. Activity you can set the minimal intensity which have to be 
considered as a valid signal.

3 Min. Size determines the smallest allowed size for the colonies.

4 Max. Size determines the largest allowed size for the colonies.

5 Circularity can be set in range of 0.001-1.000. The higher this value the rounder 
the allowed colonies.

Manual Editing of Colonies 
This pane will be needed to create undetected colonies and disjoin connected colonies 
manually. Select the upper three boxes to create colonies with appropriate shape.
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Using Edit colony pane:.

Figure 3-11 Edit Colonies Pane (Simple Mode)

1 Select the new elliptical colony by clicking to create an elliptical colony. Once you 
have selected this box, press the mouse left button an drag it diagonally till you get 
the desired shape and release it. Clicking the mouse right button confirm your new 
colony.

2 Select the new polygonal colony by clicking to create an polygonal colony. Once 
you have selected this box, press the mouse left button an drag it to the second 
vertex of your polygon and release it. The next vertices can be determined by a 
mouse click on the desired position. Repeat this till you achieve the desired form an 
confirm it wit mouse right button click.

3 Select the new auto-contour colony by clicking to create a colony consisting of 
pixels with similar intensity. Once you have selected this box, press the mouse left 
button an drag it around to get a desired form and release it.This can be confirmed 
by a mouse right button click.

4 In the Intersection Gap field you can set the distance between two connected 
colonies, which will be disjoined as described below.

new polygonal colony

new auto-contour colony

new elliptical colony

disjoin colonies
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5 Select the disjoin colony box divide two connected colonies. Press the mouse left 
button and drag it to draw an intersection curve and release it. A right click divide 
the colony.

Figure 3-12 Disjoin Connected Colonies 

In addition to tools in Edit Colony Pane, you can change the form of colonies directly on 
image. All colonies are polygons unless they are created as elliptical colonies.
To manipulate the shape and size of a colony: Double click the colony, which must be 
changed. You can now see the vertices of colony as little red squres. you can change their 
position by drag and drop or delete them by pointing them with the mouse curser and 
pressing the delete button. Once you get your desired shape and size, cavern your changes 
by a right click.

Figure 3-13 Manual Colony Manipulating 
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